Knockstrap 1.4.1

Knockout bindings to Twitter Bootstrap 3

Install-Package Knockstrap -Version 1.4.1
dotnet add package Knockstrap --version 1.4.1
<PackageReference Include="Knockstrap" Version="1.4.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Knockstrap --version 1.4.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Knockstrap, 1.4.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Knockstrap as a Cake Addin
#addin nuget:?package=Knockstrap&version=1.4.1

// Install Knockstrap as a Cake Tool
#tool nuget:?package=Knockstrap&version=1.4.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Knockstrap Build Status

⚠️ Bootstrap versions support ⚠️

If you need Bootstrap 4 support, you may use KnockstrapPlus fork. Also, you can try to search for more forks here.

I highly appreciate all contributions and feedback, but I don't use Bootstrap nor Knockout anymore, so I don't have any plans to continue development of this project.
This repository is not going to be updated for Bootstrap 4 (and further) and will continue work only with Bootstrap 3. But I continue merging patches with bugfixes for Bootstrap 3 if any appears.

Description

Knockstrap is binding library for Knockout.js, which provides bindings to Twitter Bootstrap 3 widgets

Supported widgets:
  • Modal
  • Tooltip
  • Popover
  • Alert
  • Progress
  • Toggle button
  • Radio button
  • Checkbox button
  • Carousel
  • Pagination
  • Pager

Download

Documentation/Examples

Dependencies

  • jQuery (Any compatible with Bootstrap 3 version)
  • Twitter Bootstrap 3 (CSS and JavaScript)
  • Knockout.js (>=2.3.0)

Packages

NuGet | Bower | npm

CDN

jsDelivr

Building

Building using grunt:

Install node.js and grunt plugin.

Install all grunt plugins:

npm install

Then you can build project with:

grunt

Also, you can specify custom build and temp directories:

grunt -buildPath=D:/custom/build -tempPath=D:/custom/temp

To build examples use:

grunt examples

Also, you can specify custom examples directory:

grunt -examplesPath=D:/custom/examples

To run unit-tests, use:

grunt jasmine

To run building, tests and minification, use:

grunt release 

License: MIT License

Knockstrap Build Status

⚠️ Bootstrap versions support ⚠️

If you need Bootstrap 4 support, you may use KnockstrapPlus fork. Also, you can try to search for more forks here.

I highly appreciate all contributions and feedback, but I don't use Bootstrap nor Knockout anymore, so I don't have any plans to continue development of this project.
This repository is not going to be updated for Bootstrap 4 (and further) and will continue work only with Bootstrap 3. But I continue merging patches with bugfixes for Bootstrap 3 if any appears.

Description

Knockstrap is binding library for Knockout.js, which provides bindings to Twitter Bootstrap 3 widgets

Supported widgets:
  • Modal
  • Tooltip
  • Popover
  • Alert
  • Progress
  • Toggle button
  • Radio button
  • Checkbox button
  • Carousel
  • Pagination
  • Pager

Download

Documentation/Examples

Dependencies

  • jQuery (Any compatible with Bootstrap 3 version)
  • Twitter Bootstrap 3 (CSS and JavaScript)
  • Knockout.js (>=2.3.0)

Packages

NuGet | Bower | npm

CDN

jsDelivr

Building

Building using grunt:

Install node.js and grunt plugin.

Install all grunt plugins:

npm install

Then you can build project with:

grunt

Also, you can specify custom build and temp directories:

grunt -buildPath=D:/custom/build -tempPath=D:/custom/temp

To build examples use:

grunt examples

Also, you can specify custom examples directory:

grunt -examplesPath=D:/custom/examples

To run unit-tests, use:

grunt jasmine

To run building, tests and minification, use:

grunt release 

License: MIT License

Release Notes

-

NuGet packages (1)

Showing the top 1 NuGet packages that depend on Knockstrap:

Package Downloads
FragCodeWebStarterPack
Starter pack for ASP.NET MVC5. Include: jQuery, Bootstrap, FluentBootstrap, Knockout, Knockstrap, SignalR, Knockout Validation, Knockout-select2

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
1.4.1 1,099 12/12/2020
1.4.0 41,561 7/14/2017
1.3.2 18,365 2/26/2016
1.3.1 1,793 12/3/2015
1.3.0 1,628 9/25/2015
1.2.1 3,181 3/19/2015
1.2.0 2,225 12/15/2014
1.1.0 2,921 10/9/2014
1.0.0 1,242 7/7/2014
0.4.0 1,432 4/28/2014
0.3.0 717 3/30/2014