Knockstrap 0.4.0

Knockout bindings to Twitter Bootstrap 3

There is a newer version of this package available.
See the version list below for details.
Install-Package Knockstrap -Version 0.4.0
dotnet add package Knockstrap --version 0.4.0
<PackageReference Include="Knockstrap" Version="0.4.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Knockstrap --version 0.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Knockstrap, 0.4.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Knockstrap as a Cake Addin
#addin nuget:?package=Knockstrap&version=0.4.0

// Install Knockstrap as a Cake Tool
#tool nuget:?package=Knockstrap&version=0.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

-Added unit tests via jasmine for all bindings and utility functions
-Added throwing exception, when binding is used with incompatible values
-Added unchecking of buttons for radio binding, when no buttons have passed value
-Fixed checkboxed don't have 'checked' property set to true, when checboxes are clicked for checkbox binding
-Made 'footer' property optional for modal binding
-Fixed carousel binding bugs
-Removed close callback from alert binding ('close.bs.alert' event from bootstrap can be used instead)
-Updated alert binding default template: now it require only 'message' property, 'type' property doesn't depend on template data
-Updated unwrapPoperties function: now if you pass not objects, it returns them without transformation into objects.
-Added nuget package manager support

NuGet packages (1)

Showing the top 1 NuGet packages that depend on Knockstrap:

Package Downloads
FragCodeWebStarterPack
Starter pack for ASP.NET MVC5. Include: jQuery, Bootstrap, FluentBootstrap, Knockout, Knockstrap, SignalR, Knockout Validation, Knockout-select2

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
1.4.1 1,131 12/12/2020
1.4.0 42,316 7/14/2017
1.3.2 18,369 2/26/2016
1.3.1 1,794 12/3/2015
1.3.0 1,630 9/25/2015
1.2.1 3,189 3/19/2015
1.2.0 2,227 12/15/2014
1.1.0 2,922 10/9/2014
1.0.0 1,249 7/7/2014
0.4.0 1,433 4/28/2014
0.3.0 718 3/30/2014
Show less