Eml.Contracts 7.0.12

There is a newer version of this package available.
See the version list below for details.
dotnet add package Eml.Contracts --version 7.0.12                
NuGet\Install-Package Eml.Contracts -Version 7.0.12                
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Eml.Contracts" Version="7.0.12" />                
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Eml.Contracts --version 7.0.12                
#r "nuget: Eml.Contracts, 7.0.12"                
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Eml.Contracts as a Cake Addin
#addin nuget:?package=Eml.Contracts&version=7.0.12

// Install Eml.Contracts as a Cake Tool
#tool nuget:?package=Eml.Contracts&version=7.0.12                

Common contracts for a Modular Architecture.

Product Compatible and additional computed target framework versions.
.NET net7.0 is compatible.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.
  • net7.0

    • No dependencies.

NuGet packages (3)

Showing the top 3 NuGet packages that depend on Eml.Contracts:

Package Downloads
Eml.DataRepository

DataRepository base classes using Entity Framework Code-First.

Eml.EntityBaseClasses

Common EntityBase classes for Entity Framework Code-First.

Eml.PipelineFramework

Create your modular architecture using PipelineFramework via Mef.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
8.0.0.16 110 6/1/2024
7.1.0 473 7/1/2023
7.0.12 796 4/11/2023
7.0.11 656 2/4/2023
7.0.10 533 2/1/2023
7.0.9 539 1/31/2023
7.0.8 500 1/31/2023
7.0.7 297 1/29/2023
7.0.6 624 12/2/2022
7.0.5 368 12/1/2022
7.0.4 608 12/1/2022
7.0.3 602 12/1/2022
7.0.2 1,020 11/23/2022
7.0.1 680 11/16/2022
7.0.0 642 11/11/2022
6.0.11 414 11/11/2022
6.0.10 391 11/11/2022
6.0.9 844 11/9/2022
6.0.8 1,894 11/6/2022
6.0.6 401 11/6/2022
6.0.5 1,115 10/26/2022
6.0.4 1,110 10/15/2022
6.0.3 2,021 8/27/2022
6.0.2 1,762 5/2/2022
6.0.1 1,364 5/2/2022
6.0.0 924 1/19/2022
5.0.9 1,225 1/19/2022
5.0.8 909 11/11/2021
5.0.7 808 11/8/2021
5.0.6 417 11/7/2021
5.0.5 3,442 7/5/2021
5.0.4 1,356 4/23/2021
5.0.3 2,484 3/16/2021
5.0.2 2,687 3/7/2021

EmL Contracts