vm.Aspects.Security.Cryptography.Ciphers.ProtectedData 2.1.4

THE CLASSES FROM THE CIPHERS PACKAGES DO NOT IMPLEMENT ANY CRYPTOGRAPHIC ALGORITHMS. They leverage the cryptographic algorithms implemented by the .NET cryptographic service providers.

           This package extends vm.Aspects.Security.Cryptography.Ciphers with classes dependent on System.Security.Cryptography.ProtectedData which depends on the Windows Data Protection API (DPAPI). The package can be expected to work on Windows OS only.
           * The package depends on:
           - .NET Standard
           - System.Security.Cryptography.Xml
           - System.Security.Cryptography.ProtectedData
           - vm.Aspects.Security.Cryptography.Ciphers
           - vm.Aspects.Security.Cryptography.Ciphers.Xml

Install-Package vm.Aspects.Security.Cryptography.Ciphers.ProtectedData -Version 2.1.4
dotnet add package vm.Aspects.Security.Cryptography.Ciphers.ProtectedData --version 2.1.4
<PackageReference Include="vm.Aspects.Security.Cryptography.Ciphers.ProtectedData" Version="2.1.4" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add vm.Aspects.Security.Cryptography.Ciphers.ProtectedData --version 2.1.4
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

Note: this package inherits from the Ciphers package but the name has changed for consistency's sake with the other vm.Aspects packages.
           Refactored the library to drop the dependency on Common Service Locator - no assumption of DI container anymore.
           Refactored a number of c-tors to take additional dependencies, which were previously resolved from the CSL.
           Built and tested with .NET Standard 2.0.

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
2.1.4 537 9/3/2018