paket.bootstrapper 5.0.0-rc001

A dependency manager for .NET with support for NuGet packages and git repositories.

This is a prerelease version of paket.bootstrapper.
There is a newer version of this package available.
See the version list below for details.
Install-Package paket.bootstrapper -Version 5.0.0-rc001
dotnet add package paket.bootstrapper --version 5.0.0-rc001
<PackageReference Include="paket.bootstrapper" Version="5.0.0-rc001" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add paket.bootstrapper --version 5.0.0-rc001
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

BUGFIX: Fixed dotnetcore integration:
Paket now properly understands runtime and reference assemblies
Paket now understands the runtime graph and restores runtime dependencies
New API `InstallModel.GetRuntimeAssemblies` and `InstallModel.GetRuntimeLibraries` can be used to retrieve the correct assets for a particular RID and TFM
New command `paket generate-nuspec`
New Command: `FixNuspecs` - Can fix a list of nuspec files now
New restriction system (https://github.com/fsprojects/Paket/pull/2336):
Paket is now more accurate in calculating restrictions and referencing libraries
Paket will convert (lock-)files to a new syntax (but still understands the old syntax), we might revert this within the beta phase
This should fix a bunch of edge cases and invalid behavior in combination with portable profiles and netstandard
Add support for net403 (required for some portable profiles)
PERFORMANCE: Improved performance by pre-loading requests (https://github.com/fsprojects/Paket/pull/2336)
PERFORMANCE: Report performance in a more detailed way (https://github.com/fsprojects/Paket/pull/2336)
BREAKING CHANGE: Paket simplify no longer support simplifying restrictions (https://github.com/fsprojects/Paket/pull/2336)
BREAKING CHANGE: Paket.PowerShell is no longer supported
BREAKING CHANGE: `InstallModel` API changed and Paket.Core.dll users might need to adapt
DEPRECATED: `FixNuspec` function is now obsolete, use `FixNuspecs` instead
PERFORMANCE: Improved performance for some edge case - https://github.com/fsprojects/Paket/pull/2299
BUGFIX: Better hash checks in bootstrapper - https://github.com/fsprojects/Paket/pull/2368
BUGFIX: Improved C++ support
BUGFIX: Fix Conditional Group Dependencies not working as expected - https://github.com/fsprojects/Paket/pull/2335
BUGFIX: Treat runtime dependencies as transitive deps - https://github.com/fsprojects/Paket/issues/2334
BUGFIX: Sort dependencies on obj/references files - https://github.com/fsprojects/Paket/issues/2310
BUGFIX: Support .NET moniker "&gt;= monoandroid" - https://github.com/fsprojects/Paket/issues/2246
BUGFIX: Better dependencies file parser errors
BUGFIX: "Dotnet restore" failed on .netstandard projects under 1.6 - https://github.com/fsprojects/Paket/issues/2243
BUGFIX: Paket now accepts multiple nuspec files in fix-nuspec - https://github.com/fsprojects/Paket/pull/2296
BUGFIX: Fixed pinning of .NETSTANDARD 1.6 packages - https://github.com/fsprojects/Paket/pull/2307
BUGFIX: Fixed bug with ignored argument of getPackageDetails - https://github.com/fsprojects/Paket/pull/2293
BUGFIX: HTTP dependency - strip query string to detect a file name - https://github.com/fsprojects/Paket/pull/2295
BUGFIX: Proper encoding "+" in package download url - https://github.com/fsprojects/Paket/pull/2288
BUGFIX: Paket failed when group is removed (or renamed) - https://github.com/fsprojects/Paket/pull/2281
BUGFIX: Filter .targets / .props earlier - https://github.com/fsprojects/Paket/pull/2286
BUGFIX: Downgrade to tooling 1.0 (https://github.com/fsprojects/Paket/pull/2380)
BUGFIX: Paket added too many targets and props (https://github.com/fsprojects/Paket/pull/2388)
BOOTSTRAPPER: Don't crash in DownloadHashFile (https://github.com/fsprojects/Paket/pull/2376)
BOOTSTRAPPER: Search harder for the paket.dependencies file (https://github.com/fsprojects/Paket/pull/2384)
USABILITY: Don't let build continue when paket failed - https://github.com/fsprojects/Paket/pull/2302

Dependencies

This package has no dependencies.

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
5.220.0 126 9/30/2019
5.164.0 1,201 5/17/2018
5.141.0 503 2/23/2018
5.140.0 237 2/23/2018
5.126.0 377 12/12/2017
5.125.5 317 12/11/2017
5.125.4 324 12/11/2017
5.124.0 295 11/29/2017
5.122.0 292 11/7/2017
5.105.0 288 10/4/2017
5.100.1 236 9/22/2017
5.100.0 228 9/22/2017
5.92.2 259 9/3/2017
5.81.0 319 7/21/2017
5.0.0 343 6/16/2017
5.0.0-rc001 241 6/6/2017
5.0.0-beta010 239 6/2/2017
4.7.0 346 4/25/2017
4.0.0 330 3/15/2017
4.0.0-alpha009 314 10/25/2016
4.0.0-alpha008 291 10/25/2016
3.35.0 357 1/30/2017
3.32.0 365 1/2/2017
3.27.0 361 11/10/2016
3.25.0 334 10/28/2016
3.24.0 299 10/25/2016
3.24.0-alpha001 255 10/22/2016
3.14.0 411 8/22/2016
3.0.0 519 6/15/2016
2.62.0 387 4/17/2016
2.46.0 551 1/19/2016
2.34.0 2,982 12/7/2015
2.31.0 345 12/1/2015
2.29.0 321 11/27/2015
2.27.0 340 11/19/2015
2.4.0 365 9/28/2015
1.39.0 368 9/8/2015
1.25.0 345 8/10/2015
1.11.0 370 6/8/2015
1.4.0 395 5/8/2015
1.2.2 345 4/27/2015
1.2.0 365 4/24/2015
Show less