SQLitePCL.raw_basic 0.9.0-pre8

This is a prerelease version of SQLitePCL.raw_basic.

Requires NuGet 2.8.1 or higher.

dotnet add package SQLitePCL.raw_basic --version 0.9.0-pre8
NuGet\Install-Package SQLitePCL.raw_basic -Version 0.9.0-pre8
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="SQLitePCL.raw_basic" Version="0.9.0-pre8" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add SQLitePCL.raw_basic --version 0.9.0-pre8
#r "nuget: SQLitePCL.raw_basic, 0.9.0-pre8"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install SQLitePCL.raw_basic as a Cake Addin
#addin nuget:?package=SQLitePCL.raw_basic&version=0.9.0-pre8&prerelease

// Install SQLitePCL.raw_basic as a Cake Tool
#tool nuget:?package=SQLitePCL.raw_basic&version=0.9.0-pre8&prerelease

SQLitePCL.raw is a Portable Class Library (PCL) for low-level (raw) access to SQLite.  This package does not provide an API which is friendly to app developers.  Rather, it provides an API which handles platform and configuration issues, upon which a friendlier API can be built.  On platforms (like Android or iOS) where SQLite is preinstalled, this package may be all you need.  On other platforms, or if you want to use a different SQLite build, see the SQLitePCL.plugin.* packages.  (Note that with the 0.8.0 release, the ID of this package changed from 'SQLitePCL.raw_basic' to 'SQLitePCL.raw'.  Eventually, the old ID will stop getting updates.)

Product Compatible and additional computed target framework versions.
.NET net6.0-android was computed.  net7.0-android was computed.  net8.0-android was computed. 
.NET Framework net35 is compatible.  net40 is compatible.  net403 was computed.  net45 is compatible.  net451 was computed.  net452 was computed.  net46 was computed.  net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 was computed.  net48 was computed.  net481 was computed. 
MonoAndroid monoandroid is compatible. 
MonoTouch monotouch is compatible. 
Universal Windows Platform uap was computed.  uap10.0 is compatible. 
Windows Phone wpa81 is compatible. 
Windows Store win8 is compatible.  win81 is compatible. 
Xamarin.iOS xamarinios10 is compatible. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories (10)

Showing the top 5 popular GitHub repositories that depend on SQLitePCL.raw_basic:

Repository Stars
CodeHubApp/CodeHub
CodeHub is an iOS application written using Xamarin
xamarin/mobile-samples
conceptdev/xamarin-forms-samples
Samples that use Xamarin.Forms (http://xamarin.com/forms)
flagbug/Espera
Espera is a media player that plays your music, YouTube videos, SoundCloud songs and has a special "party mode".
Clancey/gMusic
This is a multi platform music player.
Version Downloads Last updated
0.9.0-pre8 10,897 5/9/2016
0.9.0-pre7 1,217 4/18/2016
0.9.0-pre6 1,100 4/11/2016
0.9.0-pre5 1,179 3/21/2016
0.8.5 13,333 1/7/2016
0.8.5-pre4 1,389 1/6/2016
0.8.5-pre2 1,326 12/28/2015
0.8.5-pre1 2,237 11/30/2015
0.8.4 30,886 11/25/2015
0.8.3 4,603 11/23/2015
0.8.3-pre1 1,568 11/5/2015
0.8.2 32,770 8/24/2015
0.8.1 13,269 7/16/2015
0.8.1-pre2 1,589 7/10/2015
0.8.0 11,670 4/10/2015
0.8.0-pre3 1,608 4/2/2015
0.8.0-pre2 1,490 4/2/2015
0.8.0-pre1 1,476 3/16/2015
0.7.2-pre1 1,564 1/29/2015
0.7.1 140,337 1/19/2015
0.7.0 82,400 12/15/2014
0.6.4-pre1 1,986 11/3/2014
0.6.3-testing 1,842 9/26/2014
0.6.1 15,449 9/22/2014
0.6.0 1,922 9/16/2014
0.5.0 23,874 7/25/2014
0.4.0-alpha 2,998 6/30/2014
0.3.0-alpha 2,754 6/11/2014
0.2.0-alpha 1,494 6/4/2014
0.1.0-alpha 1,591 5/23/2014

Major restructuring of the NuGet packages.  Main package (SQLitePCL.raw) no longer has native code embedded in it.  For situations where you do not want to use the default SQLite for your platform, add one of the SQLitePCL.plugin.* packages.  In some cases, upgrading from previous versions will require changes.  See the SQLitePCL.raw page on GitHub for more info.