QrCodeCli 0.0.4-preview

This is a prerelease version of QrCodeCli.
There is a newer prerelease version of this package available.
See the version list below for details.
dotnet tool install --global QrCodeCli --version 0.0.4-preview
This package contains a .NET tool you can call from the shell/command line.
dotnet new tool-manifest # if you are setting up this repo
dotnet tool install --local QrCodeCli --version 0.0.4-preview
This package contains a .NET tool you can call from the shell/command line.
#tool dotnet:?package=QrCodeCli&version=0.0.4-preview&prerelease
nuke :add-package QrCodeCli --version 0.0.4-preview

.NET NuGet Coverage

QrCodeCli

A global tool to encode and decode qr codes

In this repo, i m building a global tool that allows to encode and decode qr codes.

The tool is based on two sub commands :

  • Use sub command Encode to encode qr codes
  • Use sub command Encode Url to encode url qr codes
  • Use sub command Encode Sms to encode sms qr codes
  • Use sub command Encode Mail to encode mail qr codes
  • Use sub command Encode Sepa to encode sepa qr codes
  • Use sub command Encode Wifi to encode wifi qr codes
  • Use sub command Encode Location to encode location qr codes
  • Use sub command Decode to decode qr codes

To run the tool, type commands :

  • QrCode -h to show help
  • QrCode -v to show version
  • QrCode -s to show settings
  • QrCode Encode -i [input-text] to encode qr code from plain text
  • QrCode Encode -i [input-file] to encode qr code from text file
  • QrCode Decode -i [input-file] to decode qr code from image file

To install global tool from a local source path, type commands :

  • dotnet tool install -g --configfile .\nugets\local.config QrCodeCli --version "*-*" --ignore-failed-sources

To install global tool from nuget source, type these command :

  • For stable version : dotnet tool install -g QrCodeCli --ignore-failed-sources
  • For prerelease version : dotnet tool install -g QrCodeCli --version "*-*" --ignore-failed-sources

To uninstall global tool, type these command :

  • dotnet tool uninstall -g QrCodeCli

Tools : vs22, net 6.0/7.0, qrcoder, zxing, command-line, spectre-console

Product Compatible and additional computed target framework versions.
.NET net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 is compatible.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

This package has no dependencies.

Version Downloads Last updated
0.0.5-preview 422 12/24/2023
0.0.4-preview 373 8/29/2023
0.0.3-alpha 367 8/29/2023
0.0.2-alpha 395 8/29/2023
0.0.1 473 12/24/2023
0.0.1-alpha 327 8/28/2023
0.0.0-alpha 393 8/28/2023