NeerCore.Data 1.6.1

There is a newer version of this package available.
See the version list below for details.
dotnet add package NeerCore.Data --version 1.6.1
NuGet\Install-Package NeerCore.Data -Version 1.6.1
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="NeerCore.Data" Version="1.6.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add NeerCore.Data --version 1.6.1
#r "nuget: NeerCore.Data, 1.6.1"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install NeerCore.Data as a Cake Addin
#addin nuget:?package=NeerCore.Data&version=1.6.1

// Install NeerCore.Data as a Cake Tool
#tool nuget:?package=NeerCore.Data&version=1.6.1

The NeerCore.Data package is a set of data classes used by another NeerCore.Data.* packages.

           It is a library for simplified writing of .NET apps. It integrates a popular set of core libraries that are required for developing full-fledged apps, but they don't come out of the box in ASP.NET. NeerCore can be used as shown in the examples in the official repository, or separately in parts that you need. You can also use part of the code from the repository if you do not need to include "one more nuget package" or if your project is not support the version of .NET on which NeerCore was created.

Product Compatible and additional computed target framework versions.
.NET net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (2)

Showing the top 2 NuGet packages that depend on NeerCore.Data:

Package Downloads
NeerCore.Data.EntityFramework

The NeerCore.Data.EntityFramework package is a wrapper for Microsoft.EntityFrameworkCore. It simplifies the work with this library and is integrated into the NeerCore ecosystem. It is a library for simplified writing of .NET apps. It integrates a popular set of core libraries that are required for developing full-fledged apps, but they don't come out of the box in ASP.NET. NeerCore can be used as shown in the examples in the official repository, or separately in parts that you need. You can also use part of the code from the repository if you do not need to include "one more nuget package" or if your project is not support the version of .NET on which NeerCore was created.

NeerCore.Mapping.Mapster

The NeerCore.Mapping.Mapster package is a wrapper for the Mapster package and its integration into the NeerCore ecosystem. It is a library for simplified writing of .NET apps. It integrates a popular set of core libraries that are required for developing full-fledged apps, but they don't come out of the box in ASP.NET. NeerCore can be used as shown in the examples in the official repository, or separately in parts that you need. You can also use part of the code from the repository if you do not need to include "one more nuget package" or if your project is not support the version of .NET on which NeerCore was created.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.0.1 253 4/30/2023
2.0.0 193 4/29/2023
2.0.0-beta9 131 4/12/2023
2.0.0-beta8 152 4/11/2023
2.0.0-beta7 149 4/11/2023
2.0.0-beta5 136 4/9/2023
2.0.0-beta4 139 4/7/2023
2.0.0-beta3 132 4/5/2023
2.0.0-beta2 132 4/4/2023
2.0.0-beta1 155 3/14/2023
2.0.0-alpha9 149 3/10/2023
2.0.0-alpha8 139 3/10/2023
2.0.0-alpha7 162 1/16/2023
2.0.0-alpha6 157 1/15/2023
2.0.0-alpha5 150 1/12/2023
2.0.0-alpha4 151 12/26/2022
2.0.0-alpha3 140 12/24/2022
2.0.0-alpha10 155 3/14/2023
2.0.0-alpha1 172 12/10/2022
1.6.1 609 9/28/2022
1.6.0 538 9/28/2022
1.6.0-prerelease 145 9/28/2022
1.5.4 713 8/30/2022
1.5.3 546 8/24/2022
1.5.2 564 8/20/2022
1.5.1 567 8/11/2022
1.5.0 596 8/4/2022
1.4.2 591 7/29/2022
1.4.1 571 7/29/2022
1.4.0 575 7/28/2022
1.3.1 568 7/23/2022
1.3.0 584 7/23/2022
1.2.1 622 7/21/2022
1.2.0 607 7/20/2022
1.1.1 606 7/15/2022
1.0.2 634 7/9/2022
1.0.1 394 7/9/2022
1.0.0 598 7/6/2022
1.0.0-alpha6 219 6/23/2022
1.0.0-alpha5 145 6/19/2022
1.0.0-alpha4 190 6/16/2022
1.0.0-alpha3 176 6/15/2022
1.0.0-alpha2 153 6/15/2022
1.0.0-alpha1 175 6/15/2022