Joveler.Compression.XZ 1.2.0

C# pinvoke library for liblzma (XZ Utils).
Supports Windows and Linux.

Install-Package Joveler.Compression.XZ -Version 1.2.0
dotnet add package Joveler.Compression.XZ --version 1.2.0
<PackageReference Include="Joveler.Compression.XZ" Version="1.2.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Joveler.Compression.XZ --version 1.2.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Usage

Please refer to this document.

Tested liblzma Versions

  • 5,2.2
  • 5.2.3
  • 5.2.4 (Included)

Support

Targeted .Net platforms

  • .Net Framework 4.5.1
  • .Net Standard 2.0 (.Net Framework 4.6.1+, .Net Core 2.0+)

If you need .Net Standard 1.3 support, use v1.1.2 instead.

Supported OS platforms

  • Windows x86, x64
  • Linux x64, armhf, arm64

Usage

Please refer to this document.

Tested liblzma Versions

  • 5,2.2
  • 5.2.3
  • 5.2.4 (Included)

Support

Targeted .Net platforms

  • .Net Framework 4.5.1
  • .Net Standard 2.0 (.Net Framework 4.6.1+, .Net Core 2.0+)

If you need .Net Standard 1.3 support, use v1.1.2 instead.

Supported OS platforms

  • Windows x86, x64
  • Linux x64, armhf, arm64

Release Notes

- Native support for Span
- Support dll with additional dependency
- Drop .Net Standard 1.3 support

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
1.2.0 268 4/18/2019
1.1.2 515 10/30/2018
1.1.1 126 10/29/2018
1.1.0 162 10/18/2018
1.0.0 170 9/30/2018