Rocket.Surgery.Extensions.Abstractions 2.4.0

.NET Standard 2.0
There is a newer version of this package available.
See the version list below for details.
Install-Package Rocket.Surgery.Extensions.Abstractions -Version 2.4.0
dotnet add package Rocket.Surgery.Extensions.Abstractions --version 2.4.0
<PackageReference Include="Rocket.Surgery.Extensions.Abstractions" Version="2.4.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Rocket.Surgery.Extensions.Abstractions --version 2.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Rocket.Surgery.Extensions.Abstractions, 2.4.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Rocket.Surgery.Extensions.Abstractions as a Cake Addin
#addin nuget:?package=Rocket.Surgery.Extensions.Abstractions&version=2.4.0

// Install Rocket.Surgery.Extensions.Abstractions as a Cake Tool
#tool nuget:?package=Rocket.Surgery.Extensions.Abstractions&version=2.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Package Description

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETStandard 2.0

    • No dependencies.

NuGet packages (4)

Showing the top 4 NuGet packages that depend on Rocket.Surgery.Extensions.Abstractions:

Package Downloads
Rocket.Surgery.AspNetCore

Provides feature folders via convention to a Rocket Surgery Web Application

Rocket.Surgery.Meta.System

Package Description

Rocket.Surgery.AspNetCore.FluentValidation.MediatR

Package Description

Rocket.Surgery.Operational.AspNetCore.MediatR

Package Description

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
11.3.0 77 2/19/2022
11.2.3 73 1/15/2022
11.2.2 64 1/15/2022
11.2.1 145 10/14/2021
11.2.0 148 4/29/2021
11.1.0 174 3/4/2021
11.1.0-beta.4 227 12/12/2020
11.1.0-beta.3 158 12/11/2020
11.1.0-beta.2 174 12/11/2020
11.1.0-beta.1 142 12/11/2020
11.0.1 715 12/4/2020
11.0.0 242 12/4/2020
10.0.0 1,643 9/12/2020
2.5.0 3,333 7/1/2020
2.4.0 1,308 6/25/2020
2.3.1 3,482 3/7/2020
2.3.0 880 2/22/2020
2.2.1 6,757 1/21/2020
2.2.0 6,169 1/13/2020
2.1.1 6,222 12/16/2019
2.1.0 1,145 11/24/2019
2.0.1 1,542 10/30/2019
2.0.0 2,392 9/29/2019

## v2.4.0


As part of this release we had [94 commits](https://github.com/RocketSurgeonsGuild/Extensions/compare/v2.3.1...v2.3.2) which resulted in [12 issues](https://github.com/RocketSurgeonsGuild/Extensions/milestone/18?closed=1) being closed.


__:hammer: chore__

- [__#201__](https://github.com/RocketSurgeonsGuild/Extensions/pull/201) Updated to latest nuke version and other build chores

__ mysteriouss__

- [__#210__](https://github.com/RocketSurgeonsGuild/Extensions/pull/210) logic for dependabot merging
- [__#209__](https://github.com/RocketSurgeonsGuild/Extensions/pull/209) Updated mergify
- [__#208__](https://github.com/RocketSurgeonsGuild/Extensions/pull/208) Updated some steps and yaml configuration

__ dependenciess__

- [__#211__](https://github.com/RocketSurgeonsGuild/Extensions/pull/211) Bump peaceiris/actions-label-commenter from v1 to v1.3.7
- [__#207__](https://github.com/RocketSurgeonsGuild/Extensions/pull/207) Bump RocketSurgeonsGuild/actions from v0.2.2 to v0.2.3
- [__#206__](https://github.com/RocketSurgeonsGuild/Extensions/pull/206) Bump actions/upload-artifact from v1 to v2.0.1
- [__#205__](https://github.com/RocketSurgeonsGuild/Extensions/pull/205) Bump codecov/codecov-action from v1 to v1.0.7
- [__#204__](https://github.com/RocketSurgeonsGuild/Extensions/pull/204) Bump lint-staged from 9.4.3 to 10.2.11
- [__#203__](https://github.com/RocketSurgeonsGuild/Extensions/pull/203) Bump prettier from 1.19.1 to 2.0.5
- [__#202__](https://github.com/RocketSurgeonsGuild/Extensions/pull/202) Bump husky from 3.0.9 to 4.2.5
- [__#199__](https://github.com/RocketSurgeonsGuild/Extensions/pull/199) Bump FakeItEasy from 6.0.1 to 6.1.0