PamposTools.InShell 1.0.4

.NET 5.0 .NET Core 3.1 .NET Standard 2.1 .NET Framework 4.7
dotnet add package PamposTools.InShell --version 1.0.4
NuGet\Install-Package PamposTools.InShell -Version 1.0.4
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="PamposTools.InShell" Version="1.0.4" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add PamposTools.InShell --version 1.0.4
#r "nuget: PamposTools.InShell, 1.0.4"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install PamposTools.InShell as a Cake Addin
#addin nuget:?package=PamposTools.InShell&version=1.0.4

// Install PamposTools.InShell as a Cake Tool
#tool nuget:?package=PamposTools.InShell&version=1.0.4

InShell is a library for interactive console applications. Includes common input/output helpers and is based on the Command Pattern for quickly creating tasks/actions to be executed from a console application.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows net7.0 net7.0-android net7.0-ios net7.0-maccatalyst net7.0-macos net7.0-tvos net7.0-windows
.NET Core netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.1
.NET Framework net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETCoreApp 3.1

    • No dependencies.
  • .NETFramework 4.7

    • No dependencies.
  • .NETFramework 4.7.1

    • No dependencies.
  • .NETFramework 4.7.2

    • No dependencies.
  • .NETStandard 2.1

    • No dependencies.
  • net5.0

    • No dependencies.
  • net6.0

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.4 163 7/19/2022
1.0.3 296 8/18/2021
1.0.2 277 8/7/2021
1.0.1 318 2/23/2021
1.0.0 203 2/22/2021

1.0.4
Removed support for .NET Framework 4.5.
Added support for .NET 6.0.
Added GetGuid method in InputHelper for Guid inputs.

1.0.3
Added GetDecimal and GetDateTime in InputHelper

1.0.2
Added GetString and GetInt overloads in InputHelper for specifying validation method (Contributor: aLifeOnMars)

1.0.1
Added support for .NET Framework 4.5 - 4.7.2, NET Standard 1.2 and .NET Core 3.1