PPWCode.Vernacular.Persistence.II 4.0.0

The PPWCode Vernacular Persistence library.

Requires NuGet 2.8 or higher.

Install-Package PPWCode.Vernacular.Persistence.II -Version 4.0.0
dotnet add package PPWCode.Vernacular.Persistence.II --version 4.0.0
<PackageReference Include="PPWCode.Vernacular.Persistence.II" Version="4.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add PPWCode.Vernacular.Persistence.II --version 4.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

1.0.0 Initial release PPWCode.Vernacular.Persistence.II, built against .NET 4.5.
1.0.1 Type fault.
1.0.2 Fix Name on DataMemberAttribute.
2.0.0 New functionality: Redirect use of DataAnnotations to WildExceptions.
     Improved: IsSame for VersionedPersistentObject
     Fix: PPWCODE-6, PagedList.hasNextPage
3.0.0 Add new member on ITimeProvider: UtcNow
     Add contract class for ITimeProvider
     Fix contract IPagedList
4.0.0 Refactor ObjectAlreadyChangedException
     Refactor ValidationResult to ValidationViolationException
     Adding database constraint specific exceptions

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
4.0.0 747 7/20/2018
3.0.0 325 9/1/2017
2.0.0 450 3/2/2016
1.0.0 834 7/27/2014