MvvmDialogs_.NetCore 9.1.0

dotnet add package MvvmDialogs_.NetCore --version 9.1.0
NuGet\Install-Package MvvmDialogs_.NetCore -Version 9.1.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="MvvmDialogs_.NetCore" Version="9.1.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add MvvmDialogs_.NetCore --version 9.1.0
#r "nuget: MvvmDialogs_.NetCore, 9.1.0"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install MvvmDialogs_.NetCore as a Cake Addin
#addin nuget:?package=MvvmDialogs_.NetCore&version=9.1.0

// Install MvvmDialogs_.NetCore as a Cake Tool
#tool nuget:?package=MvvmDialogs_.NetCore&version=9.1.0
Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net5.0-windows7.0 is compatible.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp3.1 is compatible. 
.NET Framework net472 is compatible.  net48 was computed.  net481 was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.
  • .NETCoreApp 3.1

    • No dependencies.
  • .NETFramework 4.7.2

    • No dependencies.
  • net5.0-windows7.0

    • No dependencies.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on MvvmDialogs_.NetCore:

Package Downloads
RFBCodeWorks.Mvvm.Dialogs

This dll relies on MvvmDialogs.IDialogService This dll provides the following: DialogServiceLocator / IDialogServiceLocator - Provides a way to locate an appropriate DialogService for a given owner window - Allows registering / unregistering dialogservices to a collection. - Allows specifying a default IDialogServiceLocator to select the appropriate DialogService from the collection. - If a customer locator is not specified, this library will use a default implementation that selects the first registered IDialogService. - The extension methods will use this locator to open a window if those methods are called. DialogService - Derived from MvvmDialogs.DialogService - Overrides the FindOwner method to allow traversing up a RFBCodeWorks.Mvvm.IViewModel chain until an owner window is located. - All instances are registered automatically to the DialogServiceLocator.RegisteredServices collection. DialogServiceExtensions - Various extension methods to avoid having to dive into the full namespace hierarchy of MvvmDialogs to generate the various objects, such as OpenFileDialog FileFilter - This class allows creation of file filters for the Open/Save file dialogs. MessageBoxSettings - Derived from MvvmDialogs.FrameworkDialogs.MessageBox.MessageBoxSettings - Provides several static methods for easier creation of common-use dialogs - Provides additional constructors - Provides a virtual 'Show(IViewModel)' dialog that can be used to show the MessageBox MvvmDialogs Dependency Notes: - Where Possible, this will target the latest release of the original maintainer's package. (.NetFramework, .Net6.0, etc) - Since this package also targets .NetCoreApp3.1 and .Net5, which have been deprecate by the original maintainer, these will depend on a seperate nuget package that retains the required functionality for this library. (Clone of main repo, just updated targets)

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
9.1.0 1,056 1/15/2023