LiteGuard.Source 0.9.0

Why, it's lighter than air!
The aim of LiteGuard is to be the most simple, unambiguous and lightweight guard clause library available.

Compatible with .NET 3.5, Mono 3.2.8, Windows Store 8, Windows Phone 8.1, Universal Apps 8.1, Xamarin.Android 1.0, Xamarin.iOS 1.0, Windows Phone Silverlight 8 and Silverlight 5 (and later versions of each).

This is the LiteGuard source code package. Also available as a binary package (LiteGuard). If your project is an application or library which is not packaged and/or exported for use in other solutions then the binary package is usually the best choice. If you are writing a library which is packaged and/or exported for use in other solutions then the source code package is usually the best choice.

After installing this package you may change the source code as required to match your coding conventions.

We all have to do our bit in working toward the ultimate number of published guard clause libraries which, at current estimates, is somewhere in the region of 6.02214129(27) × 10^23.

There is a newer version of this package available.
See the version list below for details.

Requires NuGet 2.8 or higher.

Install-Package LiteGuard.Source -Version 0.9.0
dotnet add package LiteGuard.Source --version 0.9.0
<PackageReference Include="LiteGuard.Source" Version="0.9.0">
  <PrivateAssets>all</PrivateAssets>
  <IncludeAssets>runtime; build; native; contentfiles; analyzers</IncludeAssets>
</PackageReference>
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add LiteGuard.Source --version 0.9.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

This release adds support for the new Windows Phone 8.1 platform (including Universal Apps) and Xamarin.

New: Add support for Windows Phone 8.1, Xamarin.Android 1.0 and Xamarin.iOS 1.0 - https://github.com/liteguard/liteguard/issues/81/

Fixed: Win8 target does not work - https://github.com/liteguard/liteguard/issues/86/

Breaking: Window Phone Silverlight 7, Window Phone Silverlight 7.5 and Silverlight 4 are no longer supported. Windows Phone Silverlight 8 and Silverlight 5 are still supported.

Dependencies

This package has no dependencies.

Showing the top 3 GitHub repositories that depend on LiteGuard.Source:

Repository Stars
config-r/config-r
Write your .NET configuration files in C#
xbehave/xbehave.net
✖ An xUnit.net extension for describing each step in a test with natural language.
adamralph-archive/bau
The C# task runner

Version History

Version Downloads Last updated
2.2.0 1,272 8/24/2018
2.1.0 298 7/16/2018
2.0.1 622 11/1/2017
2.0.0 255 10/15/2017
2.0.0-beta01-build19 200 10/15/2017
1.1.0 675 11/28/2016
1.0.0 542 11/8/2016
1.0.0-alpha001-build000002 340 10/20/2016
0.11.0 1,194 9/6/2015
0.10.0 1,394 12/21/2014
0.9.0 1,184 6/29/2014
0.8.1 402 6/18/2014
0.8.0 10,657 3/1/2014
0.7.0 1,576 6/18/2013
0.6.0 462 5/8/2013
0.5.0 475 3/29/2013
Show less