Gradient.Runtime 0.5.0

.NET Standard 2.0
dotnet add package Gradient.Runtime --version 0.5.0
NuGet\Install-Package Gradient.Runtime -Version 0.5.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Gradient.Runtime" Version="0.5.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Gradient.Runtime --version 0.5.0
#r "nuget: Gradient.Runtime, 0.5.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Gradient.Runtime as a Cake Addin
#addin nuget:?package=Gradient.Runtime&version=0.5.0

// Install Gradient.Runtime as a Cake Tool
#tool nuget:?package=Gradient.Runtime&version=0.5.0

Core runtime components for Gradient

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows net7.0 net7.0-android net7.0-ios net7.0-maccatalyst net7.0-macos net7.0-tvos net7.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (6)

Showing the top 5 NuGet packages that depend on Gradient.Runtime:

Package Downloads
LostTech.NumPy

.NET bindings for NumPy. Requires the actual Python with NumPy installed.

Gradient

FULL TensorFlow 1.15 for .NET with Keras. Build, train, checkpoint, execute models. Comparison with TensorFlowSharp: https://github.com/losttech/Gradient/#why-not-tensorflowsharp Comparison with TensorFlow.NET: https://github.com/losttech/Gradient/#why-not-tensorflow-net Allows building arbitrary machine learning models, training them, and loading and executing pre-trained models using the most popular machine learning framework out there: TensorFlow. All from your favorite comfy .NET language. Supports both CPU and GPU training (the later requires CUDA or a special build of TensorFlow). Provides access to full tf.keras and tf.contrib APIs, including estimators. This preview will expire. !!NOTE!! This version requires Python 3.x x64 to be installed with tensorflow or tensorflow-gpu 1.15. See the official installation instructions in https://www.tensorflow.org/install/ (ensure you are installing version 1.15 to avoid hard-to-debug issues). Please, report any issues to https://github.com/losttech/Gradient/issues For community support use https://stackoverflow.com/ with tags (must be all 3 together) tensorflow, gradient, and .net. For on-site/remote support for this preview email contact@losttech.software . More information in NuGet package release notes and at the project web page: https://github.com/losttech/Gradient .

LostTech.TensorFlow

FULL TensorFlow 2.5+ for .NET with Keras. Build, train, checkpoint, execute models. Samples: https://github.com/losttech/Gradient-Samples, https://github.com/losttech/YOLOv4, https://github.com/losttech/Siren Deep learning with .NET blog: https://ml.blogs.losttech.software/ Comparison with TensorFlowSharp: https://github.com/losttech/Gradient/#why-not-tensorflowsharp Comparison with TensorFlow.NET: https://github.com/losttech/Gradient/#why-not-tensorflow-net Allows building arbitrary machine learning models, training them, and loading and executing pre-trained models using the most popular machine learning framework out there: TensorFlow. All from your favorite comfy .NET language. Supports both CPU and GPU training (the later requires CUDA or a special build of TensorFlow). Provides access to full tf.keras, estimators and many more APIs. Free for non-commercial use. For licensing options see https://losttech.software/buy_gradient.html !!NOTE!! This version requires Python 3.x x64 to be installed with TensorFlow 2.5.x. See the official installation instructions in https://www.tensorflow.org/install/ (ensure you are installing version 2.5 to avoid hard-to-debug issues). Please, report any issues to https://github.com/losttech/Gradient/issues For community support use https://stackoverflow.com/ with tags (must be all 3 together) tensorflow, gradient, and .net. For support email contact@losttech.software . More information in NuGet package release notes and on the project web page: https://github.com/losttech/Gradient . TensorFlow, the TensorFlow logo and any related marks are trademarks of Google Inc.

LostTech.MLAgents.Environments

.NET bindings for Unity ML Agents

LostTech.Gradient.FSharp

F# helpers for Gradient (core component of LostTech.TensorFlow)

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
0.5.0 147 9/30/2022
0.4.7 353 6/25/2021
0.4.6 411 5/17/2021
0.4.5 288 5/1/2021
0.4.4 1,418 12/19/2020
0.4.3 1,072 8/13/2020
0.3.2 1,277 2/6/2020