Earthworm 2.1.0

.NET 6.0 .NET Framework 4.0
Install-Package Earthworm -Version 2.1.0
dotnet add package Earthworm --version 2.1.0
<PackageReference Include="Earthworm" Version="2.1.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Earthworm --version 2.1.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Earthworm, 2.1.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Earthworm as a Cake Addin
#addin nuget:?package=Earthworm&version=2.1.0

// Install Earthworm as a Cake Tool
#tool nuget:?package=Earthworm&version=2.1.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

A simple .NET assembly that provides an object-relational mapping abstraction layer for geodatabase feature classes and tables. It converts features and rows into a (lazy) sequence of strongly-typed objects.

*Requires ArcGIS Desktop, Engine or Server 10.0, 10.1, 10.2, 10.3, 10.4, 10.5, 10.6, 10.7, 10.8 or 10.9.

A GUI tool is available here:
https://jshirota.github.com/Earthworm/ORMappingDeploy.application

The library reference is here:
https://jshirota.github.com/Earthworm/Help/Index.html

Product Versions
.NET net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Framework net40 net403 net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • net6.0

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.1.0 137 4/5/2022