DynetSharp 1.1.0

dotnet add package DynetSharp --version 1.1.0
NuGet\Install-Package DynetSharp -Version 1.1.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="DynetSharp" Version="1.1.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add DynetSharp --version 1.1.0
#r "nuget: DynetSharp, 1.1.0"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install DynetSharp as a Cake Addin
#addin nuget:?package=DynetSharp&version=1.1.0

// Install DynetSharp as a Cake Tool
#tool nuget:?package=DynetSharp&version=1.1.0

DyNetSharp - C# wrapper for DyNet: The Dynamic Neural Network Toolkit

This is the CPU version of the package. For the GPU version, please follow the instructions in building and installing from source .

Installing the library

Prerequisites:

Before using DyNetSharp, you need to have the Microsoft Visual C++ Redistributable installed on the machine. The Visual Studio installation comes with it by default, otherwise you can download and install it from here.

Note: The library only works with x64 executables.

Building and installing from source:

See the GitHub page.

Using DyNetSharp

For the full markdown of how to use DyNetSharp, please see the GitHub page

Product Compatible and additional computed target framework versions.
.NET net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

This package has no dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.1.0 231 11/7/2023
1.0.6 1,188 10/2/2021
1.0.4 702 5/21/2019